黑莓可用的 China Google Maps 2.2.0

Google Maps虽然国际版 Google Maps 都已经 2.2.3 了,中国版谷歌手机地图 也已经 2.2.0 了,可黑莓上至今还只有 1.6.4, 没有 GPS 或者基站定位支持,没有公交、驾车指南,唯一实用的功能只是商户搜索而已。

这里是用普通 java 版修改而成的 2.2.0 黑莓版,下载从 DM 安装它。我实测下来发现定位不可用,键位也和原生黑莓版有点出入,但公交、驾车指南是实实在在支持了,地图数据源也比 1.6.4 新,值得一试。安装可能需要先卸载已有的 Google Maps. 下面是公交搜索截图:

Google Maps for BlackBerry

Google Maps for BlackBerry

Google Maps for BlackBerry

驾车的:

Google Maps for BlackBerry

Google Maps for BlackBerry

最新评论

  • 高午饭 博主现在的社交网络有么,想关注您呢 我为什么爱 Twitter
  • 西贝博客 很好的建议!谢谢分享! 如何为 blog 建立一个高效的标签系统
  • 苹果 老罗露脸了,哈哈,支持他现在的事业 我为什么爱 Twitter
  • 飞之梦 不错,第一次看到这些效果,以后要用一用了。 CSS 文字阴影在网页设计中的应用
  • QQ地带 大牛,pansou也是用的ajax search,为什么他不会被墙呢,因为他调用的地址是ip,不是直接的谷歌域名。请问怎么实现。 打造完美的 ajax 版 Google 自定义搜索

发表您的评论

您的评论将回复给 原评论者

:D:):O8):(8D;DXD:P:nice::rainbow::cafe::love::cake:

目前有 30 条评论

  

其实google map wm版的 定位 大部分机型都用不了的 唉。。。

带 GPS 的机型也不行?好久没用过wm了...

带gps的没问题 我是说google那个通过移动基站定位的功能 大部分机器都用不了

通过基站定位好象不准确……

要是很准确还要GPS干嘛,哈哈

GPS 通过手机和多颗卫星的脉冲时差来定位,精度是米级的

基站定位只是看手机在和哪几个基站通讯,再查基站位置表,精度是千米级的

老大发个java通用版的地址,上官网下载老是jad,没有jar文件啊。

我提供的下载是 alx 和 cod 文件,从黑莓桌面管理软件安装吧 😀

其他支持java 的手机,如果没有被列出,可以试一下官方页面最下方的通用版

能發一個COD到我的郵箱嗎?

在網上實在是找不到能用的,用JAD機子總是提示下載錯誤,很鬱悶啊!

i.713@163.com

萬分感謝!!!!!

好像这个是按 OS 版本区分的,所以还是自己找吧,参考一下我那篇
http://fisio.cn/access-real-download-links-of-mobile-apps.html
http://fisio.cn/mobile-user-agents-list.html

把 jad, cod 下载到电脑,传到手机上安装

4.2能用吧? :)

当然咯,其实 Google 的手机端程序都是 4.2 的,根本就没有单独做43和45...

...but我不能用...提示java.lang有问题,随便怎么换输入法都不能用,而且这个提示是Google Map的软件提示的,不是弹出窗口。

我也是,而且这个gmap没有图标的~

u got it
改得还不算好,居然定位不可用,不过1.6.4也不行,根本就没这个功能
只能等 google.cn 更新了 😛

呃..我在模拟器上试了一下,4.2.1可用,不过一定要把之前的其它版本 Google Maps or China Google Maps 删掉...

键位有什么不同之处?

一级菜单只有“搜索”和“菜单”,这显然对应了普通手机键盘的左右软键,可以用 uhjk 当方向键,但缩放不是 i/o 了,要用 1/3, 而且一定要加 ALT...

手机,那么小。有点不方便,哈哈

QVGA还行,而且已经是现在的主流配置了,更高的还有 480x360, 640x480...

:( 8310,4.2rom ,装了用不了的,提示错码

我 8310 4.5, 上面的截图是我自己截的,我在 4.2 的模拟器上也装成功了...

检查一下原来的 Google Maps, China Google Maps 是否都删掉了?

删掉Google Maps以后再装就不行。

奇了怪了,罢了罢了...等 Google.cn 更新吧...

黑莓看上去很好玩的啊……哎呀,不支持GPS么?支持蓝牙的吧

蓝牙是都有的,GPS 部分有啦

我的8700,不能用啊,提示java.lang的错误信息

不要用这个了,已经有正式新版

http://fisio.cn/blackberry-china-google-maps-232.html

8700v用原版地图定位很方便
这个不能定位...可惜了

是的,这是当时的一个权宜版本,现在有官方新的啦

手机上的屏幕太小了,而且定位的误差比较大,用起来不是很爽。